×
Hyrja
Profili

Ne phpbb 2.0.17 eshte gjetur nje Biruc

Ne phpbb 2.0.17 eshte gjetur nje Biruc

· 6 · 1658

  • Postime: 455
  • Gjinia: Mashkull
php
ne: 18-09-2005, 13:48:27
Te nderuar webmastera te cilet keni phpbb 2.0.17 eshte gjetur nje biruc tek file includes/bbcode.php

 Ju te cilet keni phpbb 2.0.17 duhet te beni ket ndyshim tek file bbcode.php


 Si duhet ta praktikoni ju ket :

  hini  ne ftp e sites te juaj p.sh www.mysite.com/

 Pastaj hini tek  follderi ku e keni Forumin dhe  pataj hini  keshtu p.sh ju e keni te instaluar forumin keshtu www.mysite.com/forum/

 ju duhet te hyni tek
/forum/includes/ dhe ta merrni filen me emerin : bbcode.php ta beni copy dhe ta qitni ne desktop dhe te beni keto ndryshime :


Hape: includes/bbcode.php

Kërko / Find (around Line 203):




Kodi: [Zgjidh]
$patterns[] = "#\[url\]([\w]+?://[^ \"\n\r\t<]*?)\[/url\]#is";
   $replacements[] = $bbcode_tpl['url1'];

   // [url]www.phpbb.com[/url] code.. (no xxxx:// prefix).
   $patterns[] = "#\[url\]((www|ftp)\.[^ \"\n\r\t<]*?)\[/url\]#is";
   $replacements[] = $bbcode_tpl['url2'];

   // [url=xxxx://www.phpbb.com]phpBB[/url] code..
   $patterns[] = "#\[url=([\w]+?://[^ \"\n\r\t<]*?)\]([^?\n\r\t].*?)\[/url\]#is";
   $replacements[] = $bbcode_tpl['url3'];

   // [url=www.phpbb.com]phpBB[/url] code.. (no xxxx:// prefix).
   $patterns[] = "#\[url=((www|ftp)\.[^ \"\n\r\t<]*?)\]([^?\n\r\t].*?)\[/url\]#is";


Riktheje ne ket / Replace with:


Kodi: [Zgjidh]
patterns[] = "#\[url\]([\w]+?://[\w\#$%&~/.\-;:=,?@\[\]+]*?)\[/url\]#is";
   $replacements[] = $bbcode_tpl['url1'];

   // [url]www.phpbb.com[/url] code.. (no xxxx:// prefix).
   $patterns[] = "#\[url\]((www|ftp)\.[\w\#$%&~/.\-;:=,?@\[\]+]*?)\[/url\]#is";
   $replacements[] = $bbcode_tpl['url2'];

   // [url=xxxx://www.phpbb.com]phpBB[/url] code..
   $patterns[] = "#\[url=([\w]+?://[\w\#$%&~/.\-;:=,?@\[\]+]*?)\]([^?\n\r\t].*?)\[/url\]#is";
   $replacements[] = $bbcode_tpl['url3'];

   // [url=www.phpbb.com]phpBB[/url] code.. (no xxxx:// prefix).
   $patterns[] = "#\[url=((www|ftp)\.[\w\#$%&~/.\-;:=,?@\[\]+]*?)\]([^?\n\r\t].*?)\[/url\]#is";

Kerko / Find (around Line 627):



Kodi: [Zgjidh]
$ret = preg_replace("#(^|[\n ])([\w]+?://[^ \"\n\r\t<]*)#is", "\\1<a href=\"\\2\" target=\"_blank\">\\2</a>", $ret);

   // matches a "www|ftp.xxxx.yyyy[/zzzz]" kinda lazy URL thing
   // Must contain at least 2 dots. xxxx contains either alphanum, or "-"
   // zzzz is optional.. will contain everything up to the first space, newline,
   // comma, double quote or <.
   $ret = preg_replace("#(^|[\n ])((www|ftp)\.[^ \"\t\n\r<]*)#is", "\\1<a href=\"http://\\2\" target=\"_blank\">\\2</a>", $ret);

Riktheje ne / Replace with:

Kodi: [Zgjidh]
$ret = preg_replace("#(^|[\n ])([\w]+?://[\w\#$%&~/.\-;:=,?@\[\]+]*)#is", "\\1<a href=\"\\2\" target=\"_blank\">\\2</a>", $ret);

   // matches a "www|ftp.xxxx.yyyy[/zzzz]" kinda lazy URL thing
   // Must contain at least 2 dots. xxxx contains either alphanum, or "-"
   // zzzz is optional.. will contain everything up to the first space, newline,
   // comma, double quote or <.
   $ret = preg_replace("#(^|[\n ])((www|ftp)\.[\w\#$%&~/.\-;:=,?@\[\]+]*)#is", "\\1<a href=\"http://\\2\" target=\"_blank\">\\2</a>", $ret);


 Njez kjo vlen per gjitha ata te cilet e kan boh download phpBB 2.0.17 qysh ne fillim  ne muajin e par te testimit .
 
 Per gjithe webmasterat e forumit ler te testojn dhe le te shikojn nese nuk e kan ndyshuar le te dyshojn ket ndyshim  qe eshte i domezdorshem per phpbb 2.0.17
« Editimi i fundit: 18-09-2005, 14:18:53 nga M A X »

  • Postime: 455
  • Gjinia: Mashkull
php
#1 ne: 18-09-2005, 13:58:37
SPAM PHPBB 2.0.17 .
 
 Qka eshte spam.

 Skam eshte kur te ju regjistrojn ne  antare ne menryre te pa drejt me nje program i cili eshte aq i afat  ne 10 sekonda eshte ne gjendje qe ti regjistron mbi 1000 antare dhe ta ngaroj database dhe  mund te publikoj nje erro ne phpbb 2.0.17 database qfare duhet te beni ju ju duhet qe te beni ate ndyshimin e lart permend dhe te beni ket ndyshim si ne foton e posht permendur ne praktik:

  • Postime: 390
  • Gjinia: Mashkull
Positive
#2 ne: 19-09-2005, 04:00:57
Te gjithe webmasteret qe kane versionin 2.0.17 te instaluar ne Forumet e tyre phpBB, ky upgradim nuk eshte i nevojshem, sepse upgradim i lartepermendur eshte vet versioni 2.0.17!

shnet e pare

  • Postime: 26634
  • Gjinia: Mashkull
M A X
#3 ne: 19-09-2005, 05:22:51
Ai po thote se eshte gjetur nje problem "bbcode.php" dhe se duhet rregulluar duke bere ndryshimet e duhura ne kod.

  • Postime: 390
  • Gjinia: Mashkull
Positive
#4 ne: 19-09-2005, 07:31:54
Une bazohem ne phpBB zyrtare (lexo: themeluesit te phpBB!) dhe upgradimin qe ka sjelle Lulikras eshte i njejti me ate te versionit 2.0.17, gjithsesi flmd per lajmin.

  • Postime: 455
  • Gjinia: Mashkull
php
#5 ne: 19-09-2005, 18:13:29
Citim
Ai po thote se eshte gjetur nje problem "bbcode.php" dhe se duhet rregulluar duke bere ndryshimet e duhura ne kod.

 Hello bro kur te ke erroa ne forum ateher errori  kur te behet me nje forum eshte sikur biruc d.th kur ke erro ne forum pa marr parasysh sa do erro qe eshte ne qofste ke vetm nje , te ngatrrume ateher ajo ( prjesje ) do te len shum  mundesi keshtu qe ti nuk e ke phpbb po ta kishe ti phpbb ta  kisha tregu pak ne praktik se qfare  mund te bjen ky erro aq i vogel se qfare mund te shkarroje
Nodshta  ju kutohet phpbb 2.0.12 se qfare ka ndodhe dhe sa viktima jan ngul ne to .. dheune kam qen ne mesin e tyre qe jamngul  nga serbian hackers